ODE upgraded from 0.6 to 0.9.1

ODE upgraded from 0.6 to 0.9.1 to conform to new swarmanoid simulator requirements.